using PEAR with package 2.0 error

Post everything else here

Moderators: Website/Forum Admins, Other/Off Topic Moderators

4105
Posts: 1
Joined: Tue Mar 27, 2007 2:38 pm

using PEAR with package 2.0 error

Postby 4105 » Mon Nov 20, 2006 1:58 pm

I am trying to add a package to pear. I am upgrading from PHP 5.0 to PHP 5.1 The OS is Redhat 8. When I attempt to install the package I get "no handlers for package.xml version 2." Current version of Archive_Tar is 1.3.1 and Pear is 1.4.11.

The package is MDB2_Driver_ibase.


FYI I am using Apache 2.x and i even attpemted to install the package from a local "tgz" file after I attempted from the regular installation. Several packages like MDB2 gave the same error when I attempted to install them.

Any assistance will be appreciated.
User avatar
Pills
Forum Admin
Posts: 312
Joined: Wed Jul 02, 2003 1:14 pm
Location: Long Island, NY
Contact:

Postby Pills » Mon Nov 20, 2006 5:42 pm

As this has nothing to do with EFnet, moved to Off Topic.
admin, irc.umich.edu
oper, irc.servercentral.net
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Postby munky » Fri Nov 24, 2006 3:59 pm

http://www.go-pear.org/manual/en/faq.no-handlers.php

Why do I get "No handlers for package.xml version 2.0" when I try to install a package?

You are using a PEAR version lower than 1.4.0.

To install the package, you have to update PEAR via:

$ pear upgrade PEAR

This will install the latest available version of PEAR which is capable of installing packages that have only a package.xml version 2.0.


you say you have pear 1.4.11, but are you sure that is the one being used? it's possible you have multiple versions installed on your system if you custom compiled PHP.
In God we trust,
Everyone else must have an X.509 certificate.

Return to “Off Topic”

Who is online

Users browsing this forum: No registered users and 1 guest