Installation of PEAR!

Post everything else here

Moderators: Website/Forum Admins, Other/Off Topic Moderators

yrstruly
Posts: 2
Joined: Wed Apr 15, 2009 4:15 pm

Installation of PEAR!

Postby yrstruly » Wed Apr 15, 2009 4:29 pm

Hi

Im having trouble with the installation of PEAR. Im running xampp latest version. I have tried the easy installation (c:\php\go-pear.bat.) , All i get is this message:The system cannot find the path specified. I have checked the path and it seems to be correct. Please help!
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Re: Installation of PEAR!

Postby munky » Thu Apr 16, 2009 3:39 pm

(moved to off topic)

what is it trying to find?
In God we trust,
Everyone else must have an X.509 certificate.
yrstruly
Posts: 2
Joined: Wed Apr 15, 2009 4:15 pm

Re: Installation of PEAR!

Postby yrstruly » Fri Apr 17, 2009 12:28 pm

what are you saying or asking/
oneoleguy
Posts: 1
Joined: Wed Jul 20, 2011 12:54 am

Re: Installation of PEAR!-and I need help!

Postby oneoleguy » Wed Jul 20, 2011 1:22 am

Hello,

I've been trying to get PEAR installed on my Hosts Server (They don't have it installed nor will they install it for me).

I ran the go-pear.php from my URL and the software installed. There ends the good news!

I've spend most all day trying to fix this error:

Fatal error: No PEAR.php in supplied PEAR directory: @pear_dir@ in /home/www/atrz.net/index.php on line 24

This in the index.php referred to in the error message:

Code: Select all

[
<?php
/**
 * Put this file in a web-accessible directory as index.php (or similar)
 * and point your webbrowser to it.
 */

// $pear_dir must point to a valid PEAR install (=contains PEAR.php)
$pear_dir = '@pear_dir@'; // default of install

// OPTIONAL: If you have a config file at a non-standard location,
// uncomment and supply it here:
//$pear_user_config = '';

// OPTIONAL: If you have protected this webfrontend with a password in a
// custom way, then uncomment to disable the 'not protected' warning:
//$pear_frontweb_protected = true;


/***********************************************************
 * Following code tests $pear_dir and loads the webfrontend:
 */
if (!file_exists($pear_dir.'/PEAR.php')) {
    trigger_error('No PEAR.php in supplied PEAR directory: '.$pear_dir,
                    E_USER_ERROR); <<<<<<<<<============================= This is line 24
}
ini_set('include_path', $pear_dir);
require_once('PEAR.php');

// Include WebInstaller
putenv('PHP_PEAR_INSTALL_DIR='.$pear_dir); // needed if unexisting config
require_once('pearfrontendweb.php');
?>
/code]

Appearantly the line:
[code]
// $pear_dir must point to a valid PEAR install (=contains PEAR.php)
$pear_dir = '@pear_dir@'; // default of install


This PHP code Isn't executing correctly and the value is not being passed on to the function ending on line 24.

Here are 2 ways to ways to the PEAR directory.

/home/www/atrz.net/PEAR/ and atrz.net/PEAR/

Changing the assignment to either of these statements fixes the issue.

I'm not that versed enough in PHP to correct it.

Could anyone advise me on how to correct this error?

Bill
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Re: Installation of PEAR!

Postby munky » Wed Jul 20, 2011 4:57 pm

$pear_dir should be set to one of the two paths you specified instead of @pear_dir@
In God we trust,

Everyone else must have an X.509 certificate.

Return to “Off Topic”

Who is online

Users browsing this forum: No registered users and 1 guest