Getting errors with webchat

Ideas, suggestions, and constructive criticisms about EFnet's Websites

Moderators: Website/Forum Admins, Website/Ideas/Suggestions Moderators

Davio
Posts: 4
Joined: Wed Jul 05, 2006 10:21 am

Getting errors with webchat

Postby Davio » Wed Jul 05, 2006 10:37 am

Did a search for this problem and didn't find any similar threads, so I am wondering if it is a problem with my computer.

Using the webchat, I am repeatedly getting the following errors in a new window after I click the login button @ http://chat.efnet.org/irc.cgi
Method Not Allowed
The requested method POST is not allowed for the URL /403.html.

Apache/1.3.33 Server at chat.efnet.org Port 80
I am using Firefox 1.5.04 on Windows XP Pro.

It shows me connecting to the server and lets me go into the chat room. But doing any kind of action (like entering a message and pressing enter, doing a whois) causes this error to open in a new window.

Since no one else seems to be having this problem, maybe it is something on my end? :(
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Postby munky » Wed Jul 05, 2006 12:52 pm

it's because you have no http_referer. firefox, your firewall, or something is blocking your referer from being sent to the server, which is causing it to deny access.
check your browser settings and/or disable your firewall and try again.
In God we trust,
Everyone else must have an X.509 certificate.
Davio
Posts: 4
Joined: Wed Jul 05, 2006 10:21 am

Postby Davio » Wed Jul 05, 2006 7:30 pm

The HTTP_REFERER? I don't have anything blocking that field from being read by any website.

I am using ZoneAlarm the free version. I know the Pro version has that feature.

I have an ASP script that checks the HTTP_REFERER field and it shows up ok.

I'm not getting an access denied to the chat server. I connect ok to the server and to the room. It's just that anything I try to do, like submit a message or enter an irc command, this error message comes up in a new window and my commands or messages doesn't go through.

So connection is ok, but not able to chat or do anything else.
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Postby munky » Thu Jul 06, 2006 11:38 am

you have something messing with HTTP_REFERER
there are dozens of users that chat without problems on webchat every day. the only thing in the configuration that can send you to /403.html is if there is no HTTP_REFERER

so, like i said, try turning off your firewall and try again. every time in the past 6 months anyone tells me they have problems with webchat, they are using zonealarm, and disabling it resolves the issue.
In God we trust,

Everyone else must have an X.509 certificate.
Davio
Posts: 4
Joined: Wed Jul 05, 2006 10:21 am

Postby Davio » Thu Jul 06, 2006 8:03 pm

Munky, I read what you're saying. That it has happened in the past with other users and the firewall was the problem. But I am finding hard to believe that, that is the problem.

But before I disable my firewall to test this, I tried login in with Opera 9 and IE 6, and they work perfectly.

So could it still be my firewall? Could it be a cookie issue? Or a javascript issue? Must be a setting I am overlooking.

Thanks for the help so far munky.
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Postby munky » Fri Jul 07, 2006 12:59 am

you're right, it seems to be something either new in firefox or in the latest updates to cgi:irc that broke the htaccess rules.
i entered an exception for firefox for now, and it should work for you again.
In God we trust,

Everyone else must have an X.509 certificate.
Davio
Posts: 4
Joined: Wed Jul 05, 2006 10:21 am

Postby Davio » Fri Jul 07, 2006 2:25 am

munky, that change works for me. :)
Thanks much. Appreciate it. :)
User avatar
deww
Posts: 125
Joined: Fri Jul 18, 2003 7:17 pm

Postby deww » Sat Jul 08, 2006 3:50 am

Not sure when the change was made, but I tested with firefox before the post about the change was made and was able to connect. Hmmm.
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Postby munky » Mon Jul 10, 2006 2:37 am

i was able to connect as well. but sending any commands (privmsg, join, etc) caused the error described.
In God we trust,

Everyone else must have an X.509 certificate.

Return to “Ideas/Suggestions”

Who is online

Users browsing this forum: No registered users and 2 guests