Help with SF-Users v1.0 and PHP 5

Post everything else here

Moderators: Website/Forum Admins, Other/Off Topic Moderators

bootup
Posts: 3
Joined: Thu Apr 06, 2006 1:34 am

Help with SF-Users v1.0 and PHP 5

Postby bootup » Thu Apr 06, 2006 1:47 am

SF users login system is by sloughflash.com it is a free user content mangement system really easy to use. I am testing locally and for some reason i am getting these errors. PHP is working 100% My SQL connects no problem. I think PHP 5 is not completely compatible with SF Users.

There are a few errors i am getting. From opening Main.PHP and trying to login

Notice: A session had already been started - ignoring session_start() in ........\functions.php on line 2

Notice: Undefined index: act in ....\register.php on line 36

I know this maybe pretty general but if anyone has had the same experience.

Thank you,
Matt
bootup
Posts: 3
Joined: Thu Apr 06, 2006 1:34 am

i might know

Postby bootup » Thu Apr 06, 2006 2:10 am

is it possible that i might have to change php.ini? for globals?
User avatar
munky
Site Admin
Posts: 826
Joined: Wed Jul 02, 2003 4:54 pm
Location: Phoenix AZ
Contact:

Postby munky » Thu Apr 06, 2006 11:48 am

php throws all kinds of garbage in logs by default that you don't need to know about on production websites.

edit your php.ini, change the 'error_reporting' line to something like this:
error_reporting = E_COMPILE_ERROR|E_ERROR|E_CORE_ERROR|E_PARSE|E_USER_ERROR

it looks as if you are using E_ALL, which gives you all kinds of notices and warnings that often cause no problems when running your website.
In God we trust,
Everyone else must have an X.509 certificate.

Who is online

Users browsing this forum: No registered users and 0 guests